AutoPower Forum

AutoPower Diskussion

3-Serien
548

Ingen data från höger bakre ABS sensor

Sida 1 av 2
bi
36
biz
430i Coupé -21
Hej,

Det gäller en 325i, E92, 2008 med N53B30 motorn.
Den la av lite sporadiskt först,men nu är det permanent.

Har kollat med INPA, de tre andra sensorerna ger data, men inte höger bak. Bytade sensorn, hjälpte inte. Kollade om kontakten som sitter i hjulhuset bakom "mattan" var i dåligt skick, men den ser väldigt fin ut, ingen oxid. Provade ändå med lite kontakt-spray, men det hjälpte inte heller.

Sen prova jag lossa och sätta dit kontakten på DSC/ABS centralenheten, med lite kontakt spray där oxå, men det ändrade inget på situationen, samma fel. Provade lossa kontakten och sätta den kanske 10 ggr, för att "skrapa bort" eventuell oxid, ingen skillnad.

Finns det skarvar/kontakter på kabeln från sensorerna på väg fram till styrenheten ? Tycker inte det borde finnas, men jag vet inte.

Det enda som är kvar sedan är väl DSC/ABS centralenheten, eller nån som har nån annan teori?

mvh H
bi
36
biz
430i Coupé -21
Ja, det skulle väl kunna vara kransen oxa som har svällt av rost. Det var lite avskavt på den gamla sensorn, men inte mycket. Men jag tycker jag borde ha haft mer intermittenta problem först om det vore kransen.
Den kånglade en eller två gånger innan den la av helt. Dessutom fick jag data från den nya sensorn i kanske 2-3 minuter innan det börja krånga igen, och den nya sensorn blev inte skavd av kransen, har haft loss den efteråt och kollat.
Is
2.227
Isåkare
Lexus IS250.
Bilen måste rulla en bit och komma upp i en viss hastighet innan systemet larmar om fel.
Om det larmar direkt är sensorn trasig, nu är din sensor hel, och du behöver byta krans.
Troligtvis har kransen spruckit.
Drivaxel höger bak byter man på en halvtimme ocm man vet vad man ska göra och har rätt verktyg.
Vänster är knöligare då avgasystemet måste lossas.
Jag har aldrig bytt bara krans då jag inte förstår hur man ska få fast den på en rostig drivknut.
bi
36
biz
430i Coupé -21
Nu har jag kollat kransen, och rengjort. Den såg hyfsat fin ut, inga sprickor och inte alltför rostig. Men det hjälpte inte. Sen mätte jag kablarna fram oxå med en ohm-meter, inget fel på kablarna. Som du sa Isåkare, om sensorn är ok (och även kabael och centralenhet) så får man inte felet förrän man börjar köra och centralenheten ser att datat från sensorerna inte stämmer, typ om det är kransen tänker jag. Men jag har felet redan från börjar när jag startar, vilket möjligen stämmer med att ingången på centralenheten är kass.... tråkigt, men jag ser inget annat alternativ nu.

Hej,

Den nya sensorn kan ju vara defekt, särskilt om du chansat på något lågpris.

Om du orkar, skifta mellan bakhjulen och se om felet följer med. Då har du en säkrare indikation. Jobbigt, men billigare än att skicka iväg och låta undersöka/laga ABS-modulen, dessutom kanske i onödan.

/Lennart
bi
36
biz
430i Coupé -21
Jo, det är sant, den kan rent teoretiskt vara trasig. Nu är det en Bosch sensor, så det är inget skräp. Tänkte jag skulle se om jag kan mäta upp att den funkar (tog bort den nya och har den lös nu). Antar att det är ett hall-element, och jag har oscilloscope, så jag bör kunna mäta att den funkar.

Får se om jag orkar skifta mellan hjulen, det är ju ett alternativ.
Jag fastnade mest för det där att den funkade i början.

Inte lätt veta vad som gav upp då. Ibland är den nya komponenten dålig, ibland är den så full av kraft att den dödar gamla trötta med-komponenter.

/Lennart
Visa användare
ProPro-medlem
12.495
bmw-slangen
323i E30 -85 track day car
120i E87 -06
BMWCS #10072
@bmwslangen (Instagram)
lenwib har helt rätt om sensorer och kvalitet - finns alltför många skräckhistorier och vittnesmål bara på det här forumet kring detta.

Nu är detta en Bosch så ska inte vara några problem.


Helt rätt, de är aktiva sensorer (bygger på MR - Magneto Resistive principen) och skickar information i form av kodade pulståg (och den nyare version av DSC-system som jag tror xD modellerna fick först bland E9x skickar även över mer info än bara rotationshastigheten).

Dessa sensorer (för den nyare versionen av DSC-system) har även en "Im alive" funktion så om hjulet står helt stilla så skickar de en strömpuls till DSC-enheten för att säga "jag lever och fungerar så var inte orolig att jag inte skickar någonting intressant just nu".

Men jag tror du har för det äldre versionen av DSC-systemet och den tror jag bara skickar kodade pulståg när den detekterar rotation.

Minns jag rätt satt det Bosch DSC8+ (aka DXC8+) i E9x xD modellerna, medans det satt Continental Teves MK60E5 i de bakhjulsdrivna E9x modellerna.



@biz : För att se om det är sensorn eller "allt det övriga" så är det bara att köra live data på de rapporterade hjulhastigheterna eller i värsta fall scoopa högra bakre sensorn (där den går in i DSC-styrenheten).

@biz : Det var däremot lite otydligt när felkoden sätts (det vill säga hur snabbt den återkommer).
Stämmer det att en felkod (numera) sätts såfort du vrider tändningen till läge II (alternativt startar bilen men låter den stå helt stilla)? Vad är det för felkod du får?

Eller menade du när du skrev "jag har felet redan från börjar när jag startar" att det inte rapporteras något hjulhastighet överhuvudtaget (från den allra första centimetern som du börjar rulla)?
bi
36
biz
430i Coupé -21
Hej,

Vad gäller felkoder;

Från början, innan jag börja byta något, hade jag två relevanta felkoder, en i motorstyrenheten, som var 0x2f4f.
Jag hade även en 0x5dc3 från DSC-enheten, den pekar om jag förstår saken rätt direkt på höger bakre sensorn.

Efter jag bytat sensorn funkade farthållaren i ca. 2 minuter sen blev det fel igen. Jag har ingen bild i telefonen på vilken felkoden var i detta läge, med andra ord, jag vet inte om det var exakt samma felkod i DSC-enheten (brukar ta kort på skärmen med mobilen för att spara det jag ser)
Det jag vet är att ABS-lampan nu tänds redan när bilen står helt stilla, och felkoden går inte att radera från DSC'n vilket jag tolkar som att den är "aktiv" redan när bilen står helt stilla. Hade det varit kransen så tycker jag inte att det borde bete sig så här, tycker det snarare pekar på en död sensor, trasig kabel eller defekt DSC. Kabeln har jag mätt så den är det inte. Sensorn kan vara trasig fastän ny, men jag håller det för osannolikt eftersom det är en Bosch, men inte helt omöjligt. Då återstår bara DSC-enheten.

@bmw-slangen: Intressant det du berätta om sensorerna, det låter som det är en digital bus, jag hade uppfattningen att det var pulserna direkt från ett hall-effekt element, men du menar alltså att det sitter digital elektronik i själva sensorn och att det sedan är digital information fram till DSC enheten? Är det en standard 1-wire bus, eller något mer "special" för bilbranschen?
Eller jag kanske missuppfattade dig, du kanske menade en puls per "hack" i kransen när du sa pulståg? Fast om den ska ge "I'm alive" info så måste det väl nästan vara en 1-wire bus? En rå signal från ett hall-element lär ju vara knäpptyst om hjulet inte rör sig.

Att koppla in oscilloscopet direkt i bilen låter lite jobbigt, vet inte hur jag ska komma in i kontakterna utan att göra "åverkan" på något. Min tanke var att om det var ett hall-element så skulle jag kunna se pulser om jag hade den "på bänken" mata med lämplig spänning, koppla in scoopet och mäta när man satte dit och drog bort en magnet. Men är det en bus så är det ju mer komplext än så.

(jobbar med hårdvaru-nära programmering, dock inte på bil-elektronik, så jag vet inte så mycket om bil-elektronik och ECUerna i en bil)
bi
36
biz
430i Coupé -21
Hittade denna, det var nåt åt detta hållet jag trodde att den fungera, och så jag tänkte testa den:





Men det var kanske det du mena @bmw-slange, jag missuppfattade nog när jag trodde att du mena att det var en 1-wire bus.
Visa användare
ProPro-medlem
12.495
bmw-slangen
323i E30 -85 track day car
120i E87 -06
BMWCS #10072
@bmwslangen (Instagram)
Helt rätt, DSC 0x5DC3 är klagomål på den högre bakre sensorn.
Felkoden DME 0x2F4F är bara ett följdfel av problemet som triggar felkoden i DSC.

Intressant att ABS-lampan tänds direkt innan bilen börjat rulla.
Samtidigt är det bra då det förenklar felsökning :-)
Yes, det indikerar att det är något annant än själva rörelsedetekteringen som inte fungerar som det ska (notera att själva rörelsedetekteringen kan också vara defekt och du kan ha multipla fel men man måste börja med det grundläggande felet först).


@biz : Vilken felkod är det som återkommer nu (när ABS-lampan tänds direkt)? Är det DSC 0x5DC3?
Jag gissar på att du inte behöver starta bilen, det räcker att du vrider tändningen till läge II så sätts felkoden - eller hur?


Du har ju en good known, så du skulle ju kunna börja scopa vänster bak som referens (och gissningsvis behöver du bara ha tändningen i läge II). Sen scopar du höger bak och identifierar alla typer av signalavvikelser.

Men i ärlighetens namn så är det snabbare och enklare att bara prova att swappa sensor (visst det är roligare att kolla på signaler och oftast lämpligare men i det här fallet så är en swaparoo nog det lämpligaste). Du kan ju ha dessa hängandes och dinglandes, du behöver inte ens skruva fast sensorerna (det räcker ju med att vrida till tändläge II så ser du direkt om det blir någon skillnad).
Visa användare
ProPro-medlem
12.495
bmw-slangen
323i E30 -85 track day car
120i E87 -06
BMWCS #10072
@bmwslangen (Instagram)
Jag skulle inte säga en buss utan mer en envägs digital signallina.

LIN-bussen (och BMW's derivat som de kallar BSD) däremot är faktiskt riktiga 1-wire bussar medans DSC-sensorerna är endast en envägs digital signal mellan två enheter.


=== Bosch DSC III 5.3/5.7 ===
Äldre system (som Bosch DSC III 5.3, 5.7 och liknande som du typiskt hittar i E38, vissa E39 modeller och annat) använder mycket riktigt Hall-effekt sensorer och dessa skickar tillbaka en (konditionerad såklart) fyrkantsvåg som direkt speglar pulserna som de uppstår utan någon logik alls.
DSC-styrenheten lägger ut en +8V spänning till DSC-sensorn och den i sin tur returnerar en fyrkantsvåg där låg nivå är runt 0.75V och hög nivå är runt 2.5V.


=== Continental Teves DSC III MK60 ===
Sen har du något äldre system (som Continental Teves DSC III MK60 och liknande som du ofta hittade i senare årsmodeller av E46 och E39) använder sig av MR sensorer.
Även här lägger DSC-styrenheten ut en spänning till DSC-sensorn, men i dessa system är det en +12V spänning som läggs ut. Även här skickas pulser tillbaka precis som du uppstår, men här är det olika strömnivåer som används där 14mA är hög logisk nivå och 7mA är låg logisk nivå.


=== Bosch DSC8+ ===
Nyare system (som Bosch DSC8+) använder sig igen av Hall-effekt sensorer men principles of operation är fortfarande väldigt lik.
Dessa system sitter typiskt på E9x xDrive modeller.
DSC-styrenheten lägger ut en supply spänning till DSC-sensorn, som i sin tur returnerar en fyrkantsvågsignal som representerar rotationshastigheten.
Men fyrkantsvågen är numera ett dataprotokoll som använder sig av PWM (pulsbreddsmodulering) där signalen är för rotationshastigheten medans pulsbredden encodar extra info som rotationsriktning, stillaståendedetektering, installationsposition och hur stort/litet air gap det är.
Dessutom när DSC-sensorn detekterar att hjulet står stilla så skickar den ut en puls med en frekvens på 4/3 Hz vilket möjliggör för DSC-styrenheten att göra en "flight check" på sina sensorer redan innan de börjat rotera.
För att möjliggöra detektering av rotationsriktning så sitter det faktiskt 3 Hall-effekt sensorer i en enda DSC-sensor (och genom lämplig offset kan man beräkna riktningen).
Den verkar även kunna känna av var den är monterad och kan känna av om magnetfältet är tillräckligt starkt för att den ska kunna fungera. Så det finns en risk att man inte kan ha just dessa sensorer dinglandes hur som helst för det finns en risk att de detekterar avsaknad av magnetfält och det sätts då en felkod för det (så gör man en swaparoo så kan det vara lämpligt att faktiskt montera dessa för att vara på den säkra sidan - eller så kan man prova på en good known och lossa den och låta den hänga utanför och se om det sätts någon felkod).
Som du förstår så behövs ett litet inbyggnadssystem för att styra, sammanställa och rapportera all denna information :-)
Som du nog även förstår så är sannolikheten nära noll att billigare eftermarknads får allt detta rätt (och att allt rapporteras rätt inom givna toleranser och att DSC-styrenheten är glad hela tiden). Därför är det så extremt viktigt numera med BMW Original (eller motsvarande) sensorer!
Visa användare
ProPro-medlem
12.495
bmw-slangen
323i E30 -85 track day car
120i E87 -06
BMWCS #10072
@bmwslangen (Instagram)
=== Continental Teves MK60E5 ===
Jag tror däremot Continental Teves MK60E5 kör med MR sensorer men skickar liknande typ av signaler.

MK60E5 är en utveckling av Continental Teves MK60E som används på min E87 om jag minns rätt.

Vissa E9x modeller fick MK60E5 (tror de med större motorer samt de med mindre motorer som hade Active Steering optionen) och vissa E9x modeller fick MK60E (de med mindre motorer då antar jag), men osäker exakt vad som hamnade var då detta är ganska rörigt.

MK60E5 bör fungera ungefär som ovan nämnda DSC8+ (då MK60E5 signalerar tillbaka exempelvis rotationsriktning vilket inte MK60E gör) och signalera på ungefär samma sätt - jag vet att extra information läggs till på data transmissionen förutom själva pulsen. Troligtvis görs det på ungefär samma sätt mellan systemen - men det kan definitivt finnas avvikelser.


=== Continental Teves MK60E ===
Detta system bör sitta på E9x med mindre motorer och även på nästan alla E87 inklusive min (dock inte E87 130i).

Jag tror detta system är i princip identiskt med MK60 som jag nämnde tidigare - dvs det lite enklare som bara trycker ut en fyrkantsvåg fast i form av olika strömnivåer där 14mA är för hög logisk nivå och 7mA är för låg logisk nivå.



=== Slutkläm ===
Och jag har bara nämnt ett gäng av de system och versioner som används, det finns fler. Och garanterat både glömt den ena och den andra detaljen.

Men förhoppningsvis ger det lite mer insyn i att bilar är mer komplicerade än vad gemene man tror :-)

Men även om man inte kan avkoda infon så måste det finnas en grundläggande signal med ett visst utseende och som måste möta vissa kriterier. Så det finns en hel del sanity checks man kan göra genom att bara scopa signalen och kolla på hur den ser ut. Speciellt om man har en good known som man kan jämföra med så kan man få ut en hel del ändåså.

Men yes, som i all felsökning gäller det att veta vad det är man felsöker på och dess principles of operation :-)
Visa användare
ProPro-medlem
12.495
bmw-slangen
323i E30 -85 track day car
120i E87 -06
BMWCS #10072
@bmwslangen (Instagram)
@biz : Köpte du rätt sensor?

Som du ser här ovan så är det lätt att köpa fel :-)

Vilket Bosch artikelnummer hade sensorn du köpte?
bi
36
biz
430i Coupé -21
@bmw-slangen:
Ja, det finns nog en stor risk att sensorn jag köpt inte är kompkatibel då. Intressant läsning för övrigt.

Jag köpte denna:
Länk

Autodoc säger att den ska passa min bil, men de har haft fel förr....

Jag gjorde oxå en test på skrivbordet med den nya sensorn, och jag måste säga att det verkar som om den är trasig. Om jag mäter i vanligt ohm-läge med min Fluke så är det avbrott, oavsett hur jag vänder probarna. Om jag mäter i diod-läge med Fluken så är det avbrott oavsett polaritet. Sen prova jag att lägga ett 1,2 kohm motstånd i serie och lägga på en matningsspänning som jag sakta drog upp. Sensorn drar absolut noll ström det blir aldrig så mycket som 1 mV över motståndet, provade båda polariteter, så vad jag kan se är den nya sensorn trasig (med det går säkert lika bra att övertyga Autodoc om som det kommer gå att övertyga en kyckling om att den går att äta)

Sen kan man ju fråga sig varför den är trasig, när den funkade i några minuter. När jag tittar noga på plastkapslingen så finns det faktiskt lite skav från kransen, så den har svällt. Men jag har mycket svårt att tro att det lilla skavet skull orsaka att sensorn slutar funka på så sätt att den är helt död på "el-sidan", men jag vet inte säkert.

Ett annat alternativ är att DSC enheten är trasig på så sätt att den låt säga lägger ut för hög spänning, har för låg impedans eller nåt åt det hållet. Jag ser det som högst osannolikt.
Visa användare
ProPro-medlem
12.495
bmw-slangen
323i E30 -85 track day car
120i E87 -06
BMWCS #10072
@bmwslangen (Instagram)
Det är rätt sensor iallafall :-)

ETK säger 34 52 6 870 076
Länk

Bosch korsrefererar till 6 870 076
Länk

De två andra artikelnummer som Bosch nämner är bara äldre som har blivit supersedade av 6 870 076
Länk
Visa användare
ProPro-medlem
12.495
bmw-slangen
323i E30 -85 track day car
120i E87 -06
BMWCS #10072
@bmwslangen (Instagram)
@biz : Tänk på att du (och YouTube-klippet) mäter på en sensor för Continental Teves DSC III MK60 system.

Men du har med största sannolikhet sensorer för ett Continental Teves MK60E5 system (6-cylindriga motorer inom E9x verkade ha fått detta system).
Detta MK60E5 systemet verkar fungera annorlunda, mer som sensorer för ett Bosch DSC8+ system.

Jag däremot har på min E87 ett Continental Teves MK60E system, och mig veterligen är det ganska likt ett vanligt MK60 system. Även de flesta E9x med 4-cylindriga motorer verkade ha fått detta system.
Notera att YouTube klippet kommer från en E9x med en 4-cylindrig motor och det är troligtvis MK60E systemet som visas där - vilket stämmer jäkligt bra med beskrivningen jag gav (har inte kollat på filmklippet förrans nu)!

Så fullt möjligt du utgår från fel system och mäter fel.

Kolla igenom min beskrivning av systemen igen så tror jag du förstår.


Men även om du skulle mäta upp att den reagerar fint på rotationer/magnetkrans så betyder det ingenting för dig. Du kommer inte en millimeter närmare ett beslut - du har ingen bättre information att agera på än vad du hade innan.
Vi vet ju att felet redan uppstår innan den ens försöker rapportera någon rotationshasighet.
Kanske det är fel på all den övriga informationen som ska rapporteras. Detta ser ju du inte på dessa tester (då behöver du oscilloskop och även kunna jämföra med en good known och även då kan det vara knepigt).
bi
36
biz
430i Coupé -21
Jovisst, om den funkar så signalerar den kanske annorlunda, men den drar noll och ingen ström inte ens nån microampere, då kan den ju inte gärna funka tycker jag. Jag kommer inte ens så långt som videon beskriver.

Man skulle ju kunna sätta den nya (ev. trasig) sensorn på vänster hjul, för att konstatera att den verkligen är trasig. Men man kommer ju inte längre för det, som jag skrev innan, det finns ju risk att om jag köper en sensor till, så går den oxå sönder med en gång pga andra fel i bilen.

Får se hur jag gör, kanske köper ny bil istället....

Oavsett, tack för all hjälp.
Visa användare
ProPro-medlem
12.495
bmw-slangen
323i E30 -85 track day car
120i E87 -06
BMWCS #10072
@bmwslangen (Instagram)
Jag misstänker att du inte kan följa videon.
Den videon är baserad på en annan typ av sensor.
Se mina tidigare inlägg.

Däremot för just den typ av sensorn så var det en ganska snygg testuppsättning.

Förutsatt man använder rätt mätmetoder (här bör man först rigga upp mot en known good sensor så man vet att sin testrigg är korrekt) och man då mäter upp att den inte ens reagerar på kransen eller är helt stendöd - då har man iallafall fått fram en viss användbar info nämligen att en ny sensor behövs i något skede av reparationen (sen om det löser eller förändrar din nuvarande felsituation är omöjligt att säga).
Men precis som du säger - tänk om det är ett yttre fel som kan skada sensorn. Inte så vanligt, men går självklart inte att utesluta helt och hållet.


Men än en gång, med stor sannolikhet så testar du sensorn på ett felaktigt / icke-giltligt sätt.

Tänk dessutom på att om du börjar gå ned och mäta på uA nivåer så måste börja bli medveten om din multimeters burden voltage och vilken range du valt (ju lägre range desto högre shunt).


När det uppstår fel på moderna bilar så väljer folk ett av dessa tre alternativ :-)
1) Tar det på försäkringen
2) Säljer bilen
3) Kör sin SOW (Smartphone On Wheels) till kommunens återvinningscentral och knuffar den i containern för elektronikskrot och beställer samtidigt en ny bil via appen
bi
36
biz
430i Coupé -21
Jag testar inte sensorn som de gör i videon, men tack i all fall.
bi
36
biz
430i Coupé -21
Nu är det löst. Slutsatsen att det var fel på sensorn eftersom den inte drog någon ström alls var riktigt. Jag tog hem en ny sensor, och det funkade med en gång. Lite skumt att en kvalitets sensor från Bosch lägger av efter några minuter, men iofs, man brukar säga att elektronik antingen går sönder när den är ganska ny eller mycket gammal.

Plus i kanten till Autodoc som utan ifrågasättande tog det på garantin, och dessutom erbjöd mig ersättning för extrakostnader, antar att de mena om jag lämnat i den på verkstad för att byta sensorn, och hade fått en räkning på jobbet.

Tack för hjälpen här, var innan inte helt säker på att det var ett hall-effekt element i en ABS givare, men det fick jag bekräftat här.

(Nu kan jag sälja den med gott samvete, som tanken var från början, blir nog en 430, G22 istället)
Du måste vara en registrerad användare för att kunna göra inlägg här.
Klicka här för att registrera dig. Registreringen är gratis.
Är du redan användare? Logga in i menyn.